<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://electionwiz.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://electionwiz.com/wp-content/themes/broadsheet/js/html5.js" type="text/javascript"></script>
	<![endif]-->
<title>Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York | The Election Wizard | The #1 Source for Populist News &amp; Wizardly Takes</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Libre+Baskerville:b:latin,latin-ext","Alegreya:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://electionwiz.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active body{font-family:"Alegreya",serif}.wf-active body, .wf-active button, .wf-active input, .wf-active select, .wf-active textarea{font-family:"Alegreya",serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"Libre Baskerville",serif;font-weight:700;font-style:normal}.wf-active h1{font-style:normal;font-weight:700}.wf-active h2{font-style:normal;font-weight:700}.wf-active h3{font-style:normal;font-weight:700}.wf-active h4{font-style:normal;font-weight:700}.wf-active h5{font-style:normal;font-weight:700}.wf-active h6{font-style:normal;font-weight:700}</style>
<script async defer data-pin-hover="true" data-pin-tall="true" data-pin-lang="en" src="//assets.pinterest.com/js/pinit.js"></script>
<style type="text/css">			.heateorSsspInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sssp_horizontal_sharing .heateorSsspSharing,.heateor_sssp_standard_follow_icons_container .heateorSsspSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sssp_horizontal_sharing .heateorSsspTCBackground{
			color:#666;
		}
				.heateor_sssp_horizontal_sharing .heateorSsspSharing:hover,.heateor_sssp_standard_follow_icons_container .heateorSsspSharing:hover{
						border-color: transparent;
		}
		.heateor_sssp_vertical_sharing .heateorSsspSharing,.heateor_sssp_floating_follow_icons_container .heateorSsspSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sssp_vertical_sharing .heateorSsspTCBackground{
			color:#666;
		}
				.heateor_sssp_vertical_sharing .heateorSsspSharing:hover,.heateor_sssp_floating_follow_icons_container .heateorSsspSharing:hover{
						border-color: transparent;
		}
		
						div.heateor_sssp_horizontal_sharing .heateorSsspSharingSvg{width:50%;margin:auto;}div.heateor_sssp_horizontal_sharing .heateor_sssp_square_count{float:left;width:50%;line-height:35px;}
				@media screen and (max-width:783px) {.heateor_sssp_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sssp_floating_follow_icons_container{display:none!important}}@media screen and (max-width:783px){div#heateor_sssp_popup_sharing_providers{width:80%;left:60%;margin-left:-50%;text-shadow: none!important;}}#heateor_sssp_popup_sharing_providers{position: fixed;top: 50%;left: 47%;background: #fafafa;width: 650px;margin:-180px 0 0 -300px;z-index: 10000000;text-shadow: none!important}div.heateor_sssp_sharing_title{text-align:center}ul.heateor_sssp_sharing_ul{width:100%;text-align:center;}div.heateor_sssp_horizontal_sharing ul.heateor_sssp_sharing_ul li{float:none!important;display:inline-block;}</style>
<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel="alternate" type="application/rss+xml" title="The Election Wizard &raquo; Feed" href="https://electionwiz.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Election Wizard &raquo; Comments Feed" href="https://electionwiz.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Election Wizard &raquo; Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York Comments Feed" href="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-184168384-1" type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.16.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-184168384-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {
						dataLayer.push( arguments );
					}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-184168384-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var noopnullfn = function () {
								return null;
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = noopfn;
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										if ( 'event' === arguments[1] ) {
											__gtagTracker( 'event', arguments[3], {
												'event_category': arguments[2],
												'event_label': arguments[4],
												'value': 1
											} );
											return;
										}
										if ( 'undefined' !== typeof ( arguments[1].hitType ) ) {
											var hitDetails = {};
											var gagtag_map = {
												'eventCategory': 'event_category',
												'eventAction': 'event_action',
												'eventLabel': 'event_label',
												'eventValue': 'event_value',
												'nonInteraction': 'non_interaction',
												'timingCategory': 'event_category',
												'timingVar': 'name',
												'timingValue': 'value',
												'timingLabel': 'event_label',
											};
											var gaKey;
											for ( gaKey in gagtag_map ) {
												if ( 'undefined' !== typeof arguments[1][gaKey] ) {
													hitDetails[gagtag_map[gaKey]] = arguments[1][gaKey];
												}
											}
											var action = 'timing' === arguments[1].hitType ? 'timing_complete' : arguments[1].eventAction;
											__gtagTracker( 'event', action, hitDetails );
										}
									}
									return;
								}
								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = function () {
								return new Tracker();
							};
							__gaTracker.getByName = noopnullfn;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
						function __gtagTracker() {
							return null;
						}
						window['__gtagTracker'] = __gtagTracker;
						window['gtag'] = __gtagTracker;
					} )();
									}
			</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/electionwiz.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-1e45dfec4c95c1ab3fe2d2e5b7ff3084' href='https://electionwiz.com/_static/??-eJytk9GS2yAMRX+oCrNpp90+dPopHQxaogYQgyAe/31x7KbZbXAyO/uG8NWRkK7HBIZjwVhU8tVRFPUbS9LmqALb6lFURq8LWkgs5U20MyKfxv8RrrZwwOzUUMlbNXg2R/A0ZJ0nJWXy2Ev1euJawGWy28KR2XAImA2quV/t8NUlnIvK2sEJo+Us8IHITZThVWtJyiW6Xb4cMLRCQ2Zt5YBYFnSDiCi0VDivlfvVYtGmwAvnAN8UReOrXQELq7sprtnDQMUwRUh6Cu0ruLbiUU8tJguWx+jn1iBgaEuVA6V/5N1LbsgeXkqmhH+5olIdPBmlRbAs7S03j2zkKul6J4th3g/oToZOl5RlibJc9kfJziPoqP1UyAikjIFquK57Hlaz4i5Q7HHe/n+ejii33dZxzj3yr2YQ5TBipiaR28dH2xvJuvl5WJuUjzRvZNzuQ9pEJhA2pD3IQWe8zGo1yNleXRVsm2YDr20b/D26nNzDj+ds2+ivfoc7ibNwPc/Sn+HH09enz1/2z/vv+z9OEiQW' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='woocommerce-layout-inline-css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='only screen and (max-width: 768px)-css-fafd4f667061cc8c479d0b5aceee0993' href='https://electionwiz.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?m=1612915316' type='text/css' media='only screen and (max-width: 768px)' />
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<style id="broadsheet-style-neuton-css" media="all">@font-face {
  font-family: 'Noto Serif';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Kaw1J5X9T9RW6j9bNfFImZDC-.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: italic;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Vaw1J5X9T9RW6j9bNfFIu0RWufeVJ.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Iaw1J5X9T9RW6j9bNfFkWbQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Law1J5X9T9RW6j9bNdOwzfRmedA.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='wp-calypso-bridge-masterbar-css' href='https://electionwiz.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/wc-calypso-bridge/store-on-wpcom/assets/css/masterbar.css?ver=1.6.0' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script src='https://electionwiz.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='monsterinsights-frontend-script-js-extra'>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/electionwiz.com","hash_tracking":"false","ua":"UA-184168384-1"};
</script>
<script type='text/javascript' src='https://electionwiz.com/_static/??-eJx9js0KwjAQhF/IbSxi0YP4KLIma9iaP7MbSt/eUHrxIgwMAzMfsxTgZENzJGbu+jSq624Q2VdUGiKnYZbDUsDmpJTUlNA8p94nLWjf5tEh5tk4OFMp9I2DkkXlN/0B+Zx9IMCEYVW2AqVS5BYNipBu31512zjwin5H3eNtnMbTcbpezqcvZuBMbA=='></script>
<script id='give-stripe-js-js-extra'>
var give_stripe_vars = {"zero_based_currency":"","zero_based_currencies_list":["JPY","KRW","CLP","ISK","BIF","DJF","GNF","KHR","KPW","LAK","LKR","MGA","MZN","VUV"],"sitename":"","checkoutBtnTitle":"Donate","publishable_key":"pk_live_SMtnnvlq4TpJelMdklNha8iD","checkout_image":"","checkout_address":"","checkout_processing_text":"Donation Processing...","give_version":"2.9.7","cc_fields_format":"multi","card_number_placeholder_text":"Card Number","card_cvc_placeholder_text":"CVC","donate_button_text":"Donate Now","element_font_styles":{"cssSrc":false},"element_base_styles":{"color":"#32325D","fontWeight":500,"fontSize":"16px","fontSmoothing":"antialiased","::placeholder":{"color":"#222222"},":-webkit-autofill":{"color":"#e39f48"}},"element_complete_styles":{},"element_empty_styles":{},"element_invalid_styles":{},"float_labels":"","base_country":"US","preferred_locale":"en"};
</script>
<script src='https://js.stripe.com/v3/?ver=2.9.7' id='give-stripe-js-js'></script>
<script id='give-js-extra'>
var give_global_vars = {"ajaxurl":"https:\/\/electionwiz.com\/wp-admin\/admin-ajax.php","checkout_nonce":"cbd78db00f","currency":"USD","currency_sign":"$","currency_pos":"before","thousands_separator":",","decimal_separator":".","no_gateway":"Please select a payment method.","bad_minimum":"The minimum custom donation amount for this form is","bad_maximum":"The maximum custom donation amount for this form is","general_loading":"Loading...","purchase_loading":"Please Wait...","textForOverlayScreen":"<h3>Processing...<\/h3><p>This will only take a second!<\/p>","number_decimals":"2","is_test_mode":"","give_version":"2.9.7","magnific_options":{"main_class":"give-modal","close_on_bg_click":false},"form_translation":{"payment-mode":"Please select payment mode.","give_first":"Please enter your first name.","give_email":"Please enter a valid email address.","give_user_login":"Invalid email address or username.","give_user_pass":"Enter a password.","give_user_pass_confirm":"Enter the password confirmation.","give_agree_to_terms":"You must agree to the terms and conditions."},"confirm_email_sent_message":"Please check your email and click on the link to access your complete donation history.","ajax_vars":{"ajaxurl":"https:\/\/electionwiz.com\/wp-admin\/admin-ajax.php","ajaxNonce":"ece70c4d67","loading":"Loading","select_option":"Please select an option","default_gateway":"paypal","permalinks":"1","number_decimals":2},"cookie_hash":"b677e0a5e26bbfb48fdfd629c97ee398","session_nonce_cookie_name":"wp-give_session_reset_nonce_b677e0a5e26bbfb48fdfd629c97ee398","session_cookie_name":"wp-give_session_b677e0a5e26bbfb48fdfd629c97ee398","delete_session_nonce_cookie":"0"};
var giveApiSettings = {"root":"https:\/\/electionwiz.com\/wp-json\/give-api\/v2\/","rest_base":"give-api\/v2"};
</script>
<script id='broadsheet-script-main-js-extra'>
var js_i18n = {"next":"next","prev":"previous","menu":"Menu"};
</script>
<script type='text/javascript' src='https://electionwiz.com/_static/??-eJyVjEsOgkAQBS/k2BlFExbGswzwhCY9n9CthNuDsnOl20pVzcW1ORmSUZFnz0mp5xcoqMKUOlajcWdObeKC46iH+beqCQ3ElSzLg0X+CN/sS7cBEdtyyqHTAfh4MXDavHu8+as/1f5y9tUKHxFOJQ=='></script>
<script src='https://www.googletagmanager.com/gtag/js?id=UA-184168384-1' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-184168384-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://electionwiz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://electionwiz.com/wp-json/wp/v2/posts/5331" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://electionwiz.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://electionwiz.com/wp-includes/wlwmanifest.xml" />
<link rel="canonical" href="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" />
<link rel='shortlink' href='https://wp.me/pcARAF-1nZ' />
<link rel="alternate" type="application/json+oembed" href="https://electionwiz.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://electionwiz.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.25.0" />
<meta name="og:availability" content="instock" />
<meta name="og:type" content="article" /><meta name="generator" content="Give v2.9.7" />
<style type='text/css'>img#wpstats{display:none}</style> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<meta name="description" content="Florida Governor Ron DeSantis (R) joined Fox&#039;s Tucker Carlson to discuss his handling of the COVID-19 outbreak. | The Election Wizard" />
<style>
	.masthead .branding h1.logo a,
	.masthead .branding h1.logo a:hover,
	.masthead .branding h2.description {
		color:#000000;
	}
</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-7753819764531142","enable_page_level_ads":true,"tag_partner":"site_kit"});</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York | The Election Wizard | The #1 Source for Populist News &amp; Wizardly Takes" />
<meta property="og:url" content="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" />
<meta property="og:description" content="Florida Governor Ron DeSantis (R) joined Fox&#039;s Tucker Carlson to discuss his handling of the COVID-19 outbreak. | The Election Wizard" />
<meta property="article:published_time" content="2021-02-16T02:14:27+00:00" />
<meta property="article:modified_time" content="2021-02-16T02:14:29+00:00" />
<meta property="og:site_name" content="The Election Wizard" />
<meta property="og:image" content="https://i1.wp.com/electionwiz.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-20.10.58.png?fit=1200%2C507&amp;ssl=1" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="507" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Wizard_Predicts" />
<meta name="twitter:text:title" content="Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York" />
<meta name="twitter:image" content="https://i1.wp.com/electionwiz.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-20.10.58.png?fit=1200%2C507&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<style type="text/css" id="custom-colors-css">.sidebar-category-summaries .item h4 span{opacity:.9}.infinite-scroll #infinite-handle span,input[type=submit],ol.commentlist li.comment .reply a,ol.commentlist li.trackback .reply a,ol.commentlist li.pingback .reply a{border:0;background-image:none}.infinite-scroll #infinite-handle span:hover,input[type=submit]:hover,ol.commentlist li.comment .reply a:hover,ol.commentlist li.trackback .reply a:hover,ol.commentlist li.pingback .reply a:hover{border:0;background-image:none}input[type=search]:focus,input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,input.settings-input:focus{outline-color:#fff !important;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;border:1px solid #e6e6e6}.primary-content nav a{background-color:#ccc}.menu-primary .menu li ul.sub-menu li{border-bottom:1px solid rgba(0,0,0,.05)}.showcase .text-by{opacity:.6}body{background-color:#fff}.menu-primary .menu li ul.sub-menu,.menu-primary .menu li.current-menu-item a{background-color:#4f4f4f}.menu-primary .menu li ul.sub-menu:before{border-bottom-color:#4f4f4f}.menu-primary .menu li ul.sub-menu,.menu-primary .menu li.current-menu-item a{color:#fff}.menu-primary .menu li ul.sub-menu li a,.menu-primary .menu li ul.sub-menu li a:hover{color:#fff}.masthead .branding h1.logo a,.masthead .branding h1.logo a:hover,.masthead .branding h2.description{color:#b30909}.widget-title{color:#b30909}.menu{border-bottom-color:#b30909}.showcase{background:#92061b}.showcase{border-bottom-color:#000}.sidebar-category-summaries .item h4 span{background-color:#000}.sidebar-category-summaries .item h4 span:hover{background-color:#000}.primary-content .primary-wrapper .item .image-meta{background-color:#000}.primary-content .primary-wrapper .item .image-meta:hover{background-color:#000}.text-by,.text-on,.commentcount,.primary-content .primary-wrapper .item .postmetadata{color:#92061b}.primary-content nav a.selected{background-color:#92061b}.main article a.post-lead-category{background-color:#92061b}.main article a.post-lead-category:hover{background-color:#000}.primary-content .primary-wrapper .item .image-meta{color:#92061b}.infinite-scroll #infinite-handle span,input[type=submit],.main .archive-pagination span.current,ol.commentlist li.comment .reply a,ol.commentlist li.trackback .reply a,ol.commentlist li.pingback .reply a{background-color:#92061b}.infinite-scroll #infinite-handle span,.infinite-scroll #infinite-handle span:hover,input[type=submit],input[type=submit]:hover,ol.commentlist li.comment .reply a:hover,ol.commentlist li.trackback .reply a:hover,ol.commentlist li.pingback .reply a:hover{background-color:#92061b}a{color:#0b2cb1}.menu-primary .menu li a{color:#0b2cb1}.menu-primary .menu ul li a:before,{color:#0b2cb1}.menu-primary .menu li.page_item_has_children>a:after,.menu-primary .menu li.menu-item-has-children>a:after{border-top-color:#0b2cb1}.menu-primary .menu li.current-menu-item.page_item_has_children>a:after,.menu-primary .menu li.current-menu-item.menu-item-has-children>a:after{border-top-color:#0b2cb1}.showcase a,.showcase a:hover,.showcase a:visited{color:#b3bff3}.posttitle,.posttitle a{color:#0b2cb1}.showcase .postmetadata,.showcase .text-by{color:#bfbfc9}.showcase{color:#161617}h3.widgettitle:before,form.searchform button.searchsubmit{color:#161617}.postmetadata{color:#161617}body{color:#161617}blockquote{border-left-color:#161617}pre{color:#161617}pre{background-color:#161617}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,input.settings-input:focus{border-color:#161617}</style>
<script data-cfasync=&quot;false&quot; type="text/javascript">
			var __ATA_PP = { pt: 1, ht: 2, tn: 'broadsheet', amp: false, siteid: 186101845, consent: 0 };
			var __ATA = __ATA || {};
			__ATA.cmd = __ATA.cmd || [];
			__ATA.criteo = __ATA.criteo || {};
			__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
<script data-cfasync=&quot;false&quot; type="text/javascript">
		(function(){var g=Date.now||function(){return+new Date};function h(a,b){a:{for(var c=a.length,d="string"==typeof a?a.split(""):a,e=0;e<c;e++)if(e in d&&b.call(void 0,d[e],e,a)){b=e;break a}b=-1}return 0>b?null:"string"==typeof a?a.charAt(b):a[b]};function k(a,b,c){c=null!=c?"="+encodeURIComponent(String(c)):"";if(b+=c){c=a.indexOf("#");0>c&&(c=a.length);var d=a.indexOf("?");if(0>d||d>c){d=c;var e=""}else e=a.substring(d+1,c);a=[a.substr(0,d),e,a.substr(c)];c=a[1];a[1]=b?c?c+"&"+b:b:c;a=a[0]+(a[1]?"?"+a[1]:"")+a[2]}return a};var l=0;function m(a,b){var c=document.createElement("script");c.src=a;c.onload=function(){b&&b(void 0)};c.onerror=function(){b&&b("error")};a=document.getElementsByTagName("head");var d;a&&0!==a.length?d=a[0]:d=document.documentElement;d.appendChild(c)}function n(a){var b=void 0===b?document.cookie:b;return(b=h(b.split("; "),function(c){return-1!=c.indexOf(a+"=")}))?b.split("=")[1]:""}function p(a){return"string"==typeof a&&0<a.length}
		function r(a,b,c){b=void 0===b?"":b;c=void 0===c?".":c;var d=[];Object.keys(a).forEach(function(e){var f=a[e],q=typeof f;"object"==q&&null!=f||"function"==q?d.push(r(f,b+e+c)):null!==f&&void 0!==f&&(e=encodeURIComponent(b+e),d.push(e+"="+encodeURIComponent(f)))});return d.filter(p).join("&")}function t(a,b){a||((window.__ATA||{}).config=b.c,m(b.url))}var u=Math.floor(1E13*Math.random()),v=window.__ATA||{};window.__ATA=v;window.__ATA.cmd=v.cmd||[];v.rid=u;v.createdAt=g();var w=window.__ATA||{},x="s.pubmine.com";
		w&&w.serverDomain&&(x=w.serverDomain);var y="//"+x+"/conf",z=window.top===window,A=window.__ATA_PP&&window.__ATA_PP.gdpr_applies,B="boolean"===typeof A?Number(A):null,C=window.__ATA_PP||null,D=z?document.referrer?document.referrer:null:null,E=z?window.location.href:document.referrer?document.referrer:null,F,G=n("__ATA_tuuid");F=G?G:null;var H=window.innerWidth+"x"+window.innerHeight,I=n("usprivacy"),J=r({gdpr:B,pp:C,rid:u,src:D,ref:E,tuuid:F,vp:H,us_privacy:I?I:null},"",".");
		(function(a){var b=void 0===b?"cb":b;l++;var c="callback__"+g().toString(36)+"_"+l.toString(36);a=k(a,b,c);window[c]=function(d){t(void 0,d)};m(a,function(d){d&&t(d)})})(y+"?"+J);}).call(this);
		</script>
<link rel="icon" href="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=270%2C270&#038;ssl=1" />
<div id="atatags-1861018452-602b2ab328d60"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018452-602b2ab328d60',
					location: 110,
					formFactor: '002',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script>

<script>
				window.ga = window.ga || function(){ ( ga.q = ga.q || [] ).push( arguments ) }; ga.l=+new Date;
				ga( 'create', 'UA-184168384-1', 'auto' );
				ga( 'require', 'ec' );
				
			</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>

</head>
<body class="post-template-default single single-post postid-5331 single-format-standard wp-embed-responsive theme-broadsheet woocommerce-no-js singular themes-sidebar1-active themes-sidebar2-active themes-sidebar3-active themes-category-summaries-inactive themes-no-featured-posts themes-no-primary-content custom-colors has-site-logo">
<div class="container hfeed">
<header class="masthead" role="banner">
<div class="branding">
<a href="https://electionwiz.com/" class="site-logo-link" rel="home" itemprop="url"><img width="360" height="360" src="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=360%2C360&amp;ssl=1" class="site-logo attachment-broadsheet-logo jetpack-lazy-image" alt="" loading="lazy" data-size="broadsheet-logo" itemprop="logo" data-attachment-id="742" data-permalink="https://electionwiz.com/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d-png/" data-orig-file="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=512%2C512&amp;ssl=1" data-orig-size="512,512" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png" data-image-description="&lt;p&gt;https://electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png&lt;/p&gt;
" data-medium-file="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?fit=512%2C512&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?w=512&amp;ssl=1 512w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=120%2C120&amp;ssl=1 120w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=360%2C360&amp;ssl=1 360w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=270%2C270&amp;ssl=1 270w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=192%2C192&amp;ssl=1 192w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=32%2C32&amp;ssl=1 32w" data-lazy-sizes="(max-width: 360px) 100vw, 360px" data-lazy-src="https://i0.wp.com/electionwiz.com/wp-content/uploads/2020/12/cropped-48088f9c-83ec-44af-8676-7f4f37b0b22d.png?resize=360%2C360&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
<h1 class="logo">
<a href="https://electionwiz.com/" title="Home">
The Election Wizard </a>
</h1>
<h2 class="description">
The #1 Source for Populist News &amp; Wizardly Takes </h2>
<div class="postmetadata">
<span class="header-date">Monday, February 15th, 2021</span> </div>
</div>
<form method="get" class="searchform" action="https://electionwiz.com/" role="search">
<label>
<span class="screen-reader">Search for...</span>
<input type="search" value="" name="s" class="searchfield text" placeholder="Search..." />
</label>
<button class="searchsubmit">&#62464;</button>
</form>
</header>
<nav class="menu-primary" role="navigation">
<div class="menu">
<h3 class="menu-toggle">Menu</h3>
<div class="menu-contact-container"><ul id="nav" class="menu-wrap clearfix"><li id="menu-item-2924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2924"><a href="https://electionwiz.com/donate/">DONATE</a></li>
<li id="menu-item-2932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-2932"><a href="https://electionwiz.com/">LATEST NEWS</a></li>
<li id="menu-item-483" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-483"><a href="https://electionwiz.com/contact/">CONTACT</a></li>
</ul></div> </div>
</nav>
<div class="main">
<div class="col-sidebar sidebar-small" role="complementary">
<div id="atatags-1861018453-602b2ab32b1f4"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018453-602b2ab32b1f4',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-1861018455-602b2ab32b21c"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018455-602b2ab32b21c',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-1861018456-602b2ab32b23d"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018456-602b2ab32b23d',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-1861018457-602b2ab32b25c"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018457-602b2ab32b25c',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-1861018458-602b2ab32b27c"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018458-602b2ab32b27c',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script><section id="give_forms_widget-2" class="widget widget_give_forms_widget"><div class="widget-wrap"><h3 class="widgettitle">Fight the Fake News! Support the Wiz.</h3> <div id="give-form-3031-wrap" class="give-form-wrap give-display-reveal">
<h2 class="give-form-title"></h2> <form id="give-form-3031-1" class="give-form give-form-3031 give-form-type-multi" action="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/?payment-mode=paypal" data-id="3031-1" data-currency_symbol="&#36;" data-currency_code="USD" data-currency_position="before" data-thousands_separator="," data-decimal_separator="." data-number_decimals="2" data-publishable-key="pk_live_SMtnnvlq4TpJelMdklNha8iD" data-account="acct_1HsvaxDwhrHKMftW" method="post">

<span class="give-hidden" style="display: none !important;">
<label for="give-form-honeypot-3031"></label>
<input id="give-form-honeypot-3031" type="text" name="give-honeypot" class="give-honeypot give-hidden" />
</span>
<input type="hidden" name="give-form-id-prefix" value="3031-1" />
<input type="hidden" name="give-form-id" value="3031" />
<input type="hidden" name="give-form-title" value="" />
<input type="hidden" name="give-current-url" value="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" />
<input type="hidden" name="give-form-url" value="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" />
<input type="hidden" name="give-form-minimum" value="5.00" />
<input type="hidden" name="give-form-maximum" value="999999.99" />
<input type="hidden" name="give-form-hash" value="71115e9385" data-time="1613441715" data-nonce-life="86400" data-donor-session="0" /><input type="hidden" name="give-price-id" value="3" /> <div class="give-total-wrap">
<div class="give-donation-amount form-row-wide">
<span class="give-currency-symbol give-currency-position-before">&#36;</span> <label class="give-hidden" for="give-amount">Donation Amount:</label>
<input class="give-text-input give-amount-top" id="give-amount" name="give-amount" type="tel" placeholder="" value="100.00" autocomplete="off">
</div>
</div>
<ul id="give-donation-level-button-wrap" class="give-donation-levels-wrap give-list-inline"><li><button type="button" data-price-id="0" class="give-donation-level-btn give-btn give-btn-level-0 " value="10.00" data-default="0">&#36;10.00</button></li><li><button type="button" data-price-id="1" class="give-donation-level-btn give-btn give-btn-level-1 " value="25.00" data-default="0">&#36;25.00</button></li><li><button type="button" data-price-id="2" class="give-donation-level-btn give-btn give-btn-level-2 " value="50.00" data-default="0">&#36;50.00</button></li><li><button type="button" data-price-id="3" class="give-donation-level-btn give-btn give-btn-level-3 give-default-level" value="100.00" data-default="1">&#36;100.00</button></li><li><button type="button" data-price-id="5" class="give-donation-level-btn give-btn give-btn-level-5 " value="250.00" data-default="0">&#36;250.00</button></li><li><button type="button" data-price-id="custom" class="give-donation-level-btn give-btn give-btn-level-custom" value="custom">Custom Amount</button></li></ul><button type="button" class="give-btn give-btn-reveal">Continue</button><input id="give-stripe-payment-method-3031-1" type="hidden" name="give_stripe_payment_method" value="">
<fieldset id="give-payment-mode-select">
<legend class="give-payment-mode-label">Select Payment Method <span class="give-loading-text"><span class="give-loading-animation"></span>
</span>
</legend>
<div id="give-payment-mode-wrap">
<ul id="give-gateway-radio-list">
<li>
<input type="radio" name="payment-mode" class="give-gateway" id="give-gateway-stripe-3031-1" value="stripe">
<label for="give-gateway-stripe-3031-1" class="give-gateway-option" id="give-gateway-option-stripe"> Credit Card</label>
</li>
<li class="give-gateway-option-selected">
<input type="radio" name="payment-mode" class="give-gateway" id="give-gateway-paypal-3031-1" value="paypal" checked='checked'>
<label for="give-gateway-paypal-3031-1" class="give-gateway-option" id="give-gateway-option-paypal"> PayPal</label>
</li>
</ul>
</div>
</fieldset>
<div id="give_purchase_form_wrap">
<fieldset id="give_checkout_user_info" class="">
<legend>
Personal Info </legend>
<p id="give-first-name-wrap" class="form-row form-row-first form-row-responsive">
<label class="give-label" for="give-first">
First Name <span class="give-required-indicator">*</span>
<span class="give-tooltip hint--top hint--medium hint--bounce" aria-label="First Name is used to personalize your donation record." rel="tooltip"><i class="give-icon give-icon-question"></i></span> </label>
<input class="give-input required" type="text" name="give_first" autocomplete="given-name" placeholder="First Name" id="give-first" value="" required aria-required="true" />
 </p>
<p id="give-last-name-wrap" class="form-row form-row-last form-row-responsive">
<label class="give-label" for="give-last">
Last Name <span class="give-tooltip hint--top hint--medium hint--bounce" aria-label="Last Name is used to personalize your donation record." rel="tooltip"><i class="give-icon give-icon-question"></i></span> </label>
<input class="give-input" type="text" name="give_last" autocomplete="family-name" id="give-last" placeholder="Last Name" value="" />
</p>
<p id="give-email-wrap" class="form-row form-row-wide">
<label class="give-label" for="give-email">
Email Address <span class="give-required-indicator">*</span>
<span class="give-tooltip hint--top hint--medium hint--bounce" aria-label="We will send the donation receipt to this address." rel="tooltip"><i class="give-icon give-icon-question"></i></span> </label>
<input class="give-input required" type="email" name="give_email" autocomplete="email" placeholder="Email Address" id="give-email" value="" required aria-required="true" />
</p>
</fieldset>
<div id="give-stripe-payment-errors-3031-1"></div> <fieldset id="give_purchase_submit" class="give-donation-submit">
<p id="give-final-total-wrap" class="form-wrap ">
<span class="give-donation-total-label">
Donation Total: </span>
<span class="give-final-total-amount" data-total="100.00">
&#36;100.00 </span>
</p>
<input type="hidden" name="give_action" value="purchase" />
<input type="hidden" name="give-gateway" value="paypal" />
<div class="give-submit-button-wrap give-clearfix">
<input type="submit" class="give-submit give-btn" id="give-purchase-button" name="give-purchase" value="Give Now" data-before-validation-label="Give Now" />
<span class="give-loading-animation"></span>
</div>
</fieldset>
</div>
</form>
</div>
</div></section> <div id="atatags-1861018459-602b2ab32d969"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018459-602b2ab32d969',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script></div>
<div class="main-content">
<article id="post-5331" class="post-5331 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
<a href="https://electionwiz.com/category/news/" class="post-lead-category">News</a>
<h1 class="title">Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York</h1> <div class="postmetadata">
<span class="text-by">By</span> <span class="author vcard"><a class="url fn n" href="https://electionwiz.com/author/theelectionwizard/" title="View all posts by The Wiz" rel="author">The Wiz</a></span> <span class="text-on">on</span> <a href="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" title="21:14" rel="bookmark"><time class="entry-date" datetime="2021-02-15T21:14:27-05:00">February 15, 2021</time></a> <span class="sep sep-commentcount">&bull;</span> <span class="commentcount">( <a href="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/#respond">Leave a comment</a> )</span>
</div>
<section class="entry">
<div class='heateorSsspClear'></div><div class='heateor_sssp_sharing_container heateor_sssp_horizontal_sharing' heateor-sssp-data-href='https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/'><div class='heateor_sssp_sharing_title' style="font-weight:bold">Share Now</div><ul class="heateor_sssp_sharing_ul heateor_sssp_ul_instance_10"><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Twitter" Title="Twitter" class="heateorSsspSharing heateorSsspTwitterBackground" onclick='heateorSsspPopup("http://twitter.com/intent/tweet?text=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York&#038;url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspTwitterSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_twitter_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Parler" Title="Parler" class="heateorSsspSharing heateorSsspParlerBackground" onclick='heateorSsspPopup("https://parler.com/new-post?message=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York&#038;url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspParlerSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_parler_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Facebook" Title="Facebook" class="heateorSsspSharing heateorSsspFacebookBackground" onclick='heateorSsspPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspFacebookSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_facebook_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Reddit" Title="Reddit" class="heateorSsspSharing heateorSsspRedditBackground" onclick='heateorSsspPopup("http://reddit.com/submit?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;title=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspRedditSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_reddit_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Telegram" Title="Telegram" class="heateorSsspSharing heateorSsspTelegramBackground" onclick='heateorSsspPopup("https://telegram.me/share/url?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;text=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspTelegramSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_Telegram_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><ss class="heateor_sssp_square_count">&nbsp;</ss><i style="width:70px;height:35px;" title="More" alt="More" class="heateorSsspSharing heateorSsspMoreBackground" onclick="heateorSsspMoreSharingPopup(this, 'https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/', 'Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York', '' )"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspMoreSvg"></ss></i></li><li class="heateorSsspSharingRound"><ss class="heateor_sssp_square_count">&nbsp;</ss><i style="width:70px;height:35px;margin-left:9px !important;" title="Total Shares" class="heateorSsspSharing heateorSsspTCBackground"></i></li></ul></div><div class='heateorSsspClear'></div><br />
<p>Feb. 15, 2021</p>
<p>Florida Governor Ron DeSantis (R) joined Fox&#8217;s Tucker Carlson to discuss his handling of the COVID-19 outbreak. </p>
<p>During the interview, DeSantis said Florida is open for business and has much lower per capita COVID numbers than most states. DeSantis said the facts on the ground don&#8217;t lie. &#8220;When I go around Florida, I will see New York license plates here. I doubt you see very many Florida license plates making their way to New York right now,&#8221; the governor said.</p>
<p>Watch DeSantis&#8217;s interview <a href="https://twitter.com/DailyCaller/status/1361488972296445955?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1361488972296445955%7Ctwgr%5E%7Ctwcon%5Es1_c10&amp;ref_url=https%3A%2F%2Felectionwiz.com%2Fwp-admin%2Fpost-new.php%3Fcalypsoify%3D1block-editor%3D1frame-nonce%3D16135272763A1908173603Aa32c1718c479ccad11740cd5a39cf422origin%3Dhttps3A2F2Fwordpress.comenvironment-id%3Dproductionsupport_user_support_token" data-type="URL" data-id="https://twitter.com/DailyCaller/status/1361488972296445955?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1361488972296445955%7Ctwgr%5E%7Ctwcon%5Es1_c10&amp;ref_url=https%3A%2F%2Felectionwiz.com%2Fwp-admin%2Fpost-new.php%3Fcalypsoify%3D1block-editor%3D1frame-nonce%3D16135272763A1908173603Aa32c1718c479ccad11740cd5a39cf422origin%3Dhttps3A2F2Fwordpress.comenvironment-id%3Dproductionsupport_user_support_token">here</a>. </p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Florida <a href="https://twitter.com/GovRonDeSantis?ref_src=twsrc%5Etfw">@GovRonDeSantis</a> on Tucker:<br><br>&quot;When I go around Florida, I will see New York license plates here. I doubt you see very many Florida license plates making their way to New York right now.&quot; <a href="https://t.co/3KiBsT2opD">pic.twitter.com/3KiBsT2opD</a></p>&mdash; Daily Caller (@DailyCaller) <a href="https://twitter.com/DailyCaller/status/1361488972296445955?ref_src=twsrc%5Etfw">February 16, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<br /><div class='heateorSsspClear'></div><div class='heateor_sssp_sharing_container heateor_sssp_horizontal_sharing' heateor-sssp-data-href='https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/'><div class='heateor_sssp_sharing_title' style="font-weight:bold">Share Now</div><ul class="heateor_sssp_sharing_ul heateor_sssp_ul_instance_8"><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Twitter" Title="Twitter" class="heateorSsspSharing heateorSsspTwitterBackground" onclick='heateorSsspPopup("http://twitter.com/intent/tweet?text=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York&#038;url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspTwitterSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_twitter_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Parler" Title="Parler" class="heateorSsspSharing heateorSsspParlerBackground" onclick='heateorSsspPopup("https://parler.com/new-post?message=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York&#038;url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspParlerSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_parler_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Facebook" Title="Facebook" class="heateorSsspSharing heateorSsspFacebookBackground" onclick='heateorSsspPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspFacebookSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_facebook_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Facebook Messenger" Title="Facebook Messenger" class="heateorSsspSharing heateorSsspFacebookMessengerBackground" onclick='heateorSsspPopup("https://www.facebook.com/dialog/send?app_id=1904103319867886&#038;display=popup&#038;link=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;redirect_uri=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspFacebookMessengerSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_Facebook_Messenger_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Reddit" Title="Reddit" class="heateorSsspSharing heateorSsspRedditBackground" onclick='heateorSsspPopup("http://reddit.com/submit?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;title=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspRedditSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_reddit_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Linkedin" Title="Linkedin" class="heateorSsspSharing heateorSsspLinkedinBackground" onclick='heateorSsspPopup("http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;title=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspLinkedinSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_linkedin_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Whatsapp" Title="Whatsapp" class="heateorSsspSharing heateorSsspWhatsappBackground"><a href="https://web.whatsapp.com/send?text=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F" rel="nofollow noopener" target="_blank"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspWhatsappSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_whatsapp_count">&nbsp;</ss></a></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="Telegram" Title="Telegram" class="heateorSsspSharing heateorSsspTelegramBackground" onclick='heateorSsspPopup("https://telegram.me/share/url?url=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F&#038;text=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York")'><ss style="display:block;" class="heateorSsspSharingSvg heateorSsspTelegramSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_Telegram_count">&nbsp;</ss></i></li><li class="heateorSsspSharingRound"><i style="width:70px;height:35px;" alt="SMS" Title="SMS" class="heateorSsspSharing heateorSsspSMSBackground"><a href="sms:?&#038;body=Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F" rel="nofollow"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspSMSSvg"></ss><ss class="heateor_sssp_square_count heateor_sssp_SMS_count">&nbsp;</ss></a></i></li><li class="heateorSsspSharingRound"><ss class="heateor_sssp_square_count">&nbsp;</ss><i style="width:70px;height:35px;" title="More" alt="More" class="heateorSsspSharing heateorSsspMoreBackground" onclick="heateorSsspMoreSharingPopup(this, 'https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/', 'Ron%20DeSantis%20tells%20Tucker%20Carlson%3A%20%27I%20doubt%20you%20see%20very%20many%20Florida%20licenses%20plates%27%20in%20New%20York', '' )"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspMoreSvg"></ss></i></li><li class="heateorSsspSharingRound"><ss class="heateor_sssp_square_count">&nbsp;</ss><i style="width:70px;height:35px;margin-left:9px !important;" title="Total Shares" class="heateorSsspSharing heateorSsspTCBackground"></i></li></ul></div><div class='heateorSsspClear'></div> <div id="atatags-1861018451-602b2ab32ea9f"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-1861018451-602b2ab32ea9f',
					location: 120,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> <div class="taxonomies">
<p class="tax-categories taxonomy">
Categories: <a href="https://electionwiz.com/category/news/" rel="category tag">News</a> </p>
</div>
</section>
</article>
<nav class="postnav">
<h1 class="screen-reader">Post navigation</h1>
<div class="prev">
<span class="more-link"><a href="https://electionwiz.com/2021/02/15/cuomo-i-accept-responsibility-for-letting-people-think-i-did-something-wrong/" rel="prev">CUOMO: &#8216;I accept responsibility&#8217; for letting people think I did something wrong</a></span>
</div>
</nav>
<section class="content-comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Tell the Wiz what you think! <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=186101845&#038;postid=5331&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Tell+the+Wiz+what+you+think%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.4&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=c5ae91788f60c473fe28a39c4a05e72b0755112e#parent=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</section>
</div>
</div>
<div class="col-sidebar sidebar-main" role="complementary">
<div id="atatags-18610184510-602b2ab32f68f"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184510-602b2ab32f68f',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184511-602b2ab32f6b5"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184511-602b2ab32f6b5',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184512-602b2ab32f6d6"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184512-602b2ab32f6d6',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script>
<section id="recent-posts-2" class="widget widget_recent_entries"><div class="widget-wrap">
<h3 class="widgettitle">Latest News</h3><nav role="navigation" aria-label="Latest News">
<ul>
<li>
<a href="https://electionwiz.com/2021/02/15/ron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york/" aria-current="page">Ron DeSantis tells Tucker Carlson: &#8216;I doubt you see very many Florida licenses plates&#8217; in New York</a>
</li>
<li>
<a href="https://electionwiz.com/2021/02/15/cuomo-i-accept-responsibility-for-letting-people-think-i-did-something-wrong/">CUOMO: &#8216;I accept responsibility&#8217; for letting people think I did something wrong</a>
</li>
<li>
<a href="https://electionwiz.com/2021/02/15/lincoln-project-implodes-fundraising-page-shutdown-as-allegations-mount/">Lincoln Project implodes, fundraising page shutdown as allegations mount</a>
</li>
<li>
<a href="https://electionwiz.com/2021/02/15/bannon-trump-may-run-for-congress-and-lead-impeachment-against-biden/">Bannon: Trump may run for Congress and lead impeachment against Biden</a>
</li>
<li>
<a href="https://electionwiz.com/2021/02/15/fans-fly-by-mar-a-lago-with-valentines-day-card-for-president-trump/">Fans Fly-by Mar-A-Lago with Valentines Day Card for President Trump</a>
</li>
</ul>
</nav></div></section> <div id="atatags-18610184513-602b2ab32fc2e"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184513-602b2ab32fc2e',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184514-602b2ab32fc54"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184514-602b2ab32fc54',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184515-602b2ab32fc76"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184515-602b2ab32fc76',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184516-602b2ab32fc96"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184516-602b2ab32fc96',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184517-602b2ab32fcb5"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184517-602b2ab32fcb5',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184518-602b2ab32fcd4"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184518-602b2ab32fcd4',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184519-602b2ab32fcf4"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184519-602b2ab32fcf4',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184520-602b2ab32fd14"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184520-602b2ab32fd14',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script><section id="heateor_sssp_follow-2" class="widget widget_heateor_sssp_follow"><div class="widget-wrap"><div class="heateor_sssp_follow_icons_container"><h3 class="widgettitle">Follow the Wiz</h3><ul class="heateor_sssp_follow_ul"><li class="heateorSsspSharingRound"><i style="width:32px;height:32px;" alt="Twitter" title="Twitter" class="heateorSsspSharing heateorSsspTwitterBackground"><a target="_blank" aria-label="Twitter" href="https://twitter.com/Wizard_Predicts" rel="noopener"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspTwitterSvg"></ss></a></i></li><li class="heateorSsspSharingRound"><i style="width:32px;height:32px;" alt="Parler" title="Parler" class="heateorSsspSharing heateorSsspParlerBackground"><a target="_blank" aria-label="Parler" href="https://parler.com/profile/TheElectionWizard/posts" rel="noopener"><ss style="display:block" class="heateorSsspSharingSvg heateorSsspParlerSvg"></ss></a></i></li></ul><div style="clear:both"></div></div></div></section></div>
</div>
<footer role="contentinfo" id="footer" class="container">
<aside class="footer-widgets sidebar-footer">
<section id="twitter_timeline-6" class="widget widget_twitter_timeline"><div class="widget-wrap"><h3 class="widgettitle">Follow the Wiz</h3><a class="twitter-timeline" data-width="600" data-height="300" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/Wizard_Predicts" href="https://twitter.com/Wizard_Predicts">My Tweets</a></div></section> <div id="atatags-18610184521-602b2ab32fe98"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184521-602b2ab32fe98',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184522-602b2ab32febb"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184522-602b2ab32febb',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184523-602b2ab32fedb"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184523-602b2ab32fedb',
					location: 150,
					formFactor: '003',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184524-602b2ab32fefa"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184524-602b2ab32fefa',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script> <div id="atatags-18610184525-602b2ab32ff19"></div>
<script>
			__ATA.cmd.push(function() {
				__ATA.initDynamicSlot({
					id: 'atatags-18610184525-602b2ab32ff19',
					location: 150,
					formFactor: '001',
					label: {
						text: 'Advertisements',
					},
					creative: {
						reportAd: {
							text: 'Report this ad',
						},
						privacySettings: {
							text: 'Privacy settings',
						}
					}
				});
			});
		</script><section id="eu_cookie_law_widget-4" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap">
<div class="hide-on-button ads-active" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
<a href="https://automattic.com/cookies/" rel="nofollow">
Cookie Policy	</a>
</div>
</div></section><section id="wordads_ccpa_do_not_sell_link_widget-5" class="widget widget_wordads_ccpa_do_not_sell_link_widget"><div class="widget-wrap"><a href="#" class="ccpa-do-not-sell" style="display: none;">Do Not Sell My Personal Information</a></div></section> </aside>
<section class="footer-wrap">
<ul class="footer-site-content-links">
<li class="footer-top-categories"><strong>Top categories: </strong> <a href="https://electionwiz.com/category/election/">Election</a> <a href="https://electionwiz.com/tag/lin-wood/">lin wood</a></li> </ul>
<div class="footer-credits">
<a></a>
<span class="sep" role="separator" aria-hidden="true"> | </span>
</div>
</section>
</footer>

<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202107'></script>
<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})()
	</script>
<script type="text/javascript">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</script><script id='contact-form-7-js-extra'>
var wpcf7 = {"apiSettings":{"root":"https:\/\/electionwiz.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script id='stripe-handler-ng-js-extra'>
var wpASPNG = {"iframeUrl":"https:\/\/electionwiz.com\/?asp_action=show_pp","prefetch":"0","ckey":"a072abab435123c7c0dcd8d815731574"};
</script>
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/electionwiz.com","is_cart":"","cart_redirect_after_add":"no"};
</script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script type='text/javascript' src='https://electionwiz.com/_static/??-eJydkE1OxDAMhS9EahXEIBaINQdgjVInM+M2iUPsqJrbE9pKjARFgpX/3vuceM4GOalPCjnUEyWB0Wu2OMEbJYShUnCQz6ycttBFSt0oN/N3K/IQGCcBR6IwfjWMTRStEu87k1pUc+QSzQO01aE6L58MwUJZZcco2qbeZHuJrS2Q6xAIwYp4Xe2r4GyTC76YdNoBzczIMfqC/so9vldfLmb5RaWt7Jby9eWXS/xMO5ZF5sA6Z5QN2qJ/hozShDyRb1m3Zv9/yNV4gzzHp/7Q3z7293f94QO41M6h'></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_f068ac41375647d71a13c4d198708abe","fragment_name":"wc_fragments_f068ac41375647d71a13c4d198708abe","request_timeout":"5000"};
</script>
<script src='https://electionwiz.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.0.0' id='wc-cart-fragments-js'></script>
<script id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script type='text/javascript' src='https://electionwiz.com/_static/??-eJyVjLEOwjAMRH+IYEVFZUJ8CgqJVbm1nahxFPH3ZGCgAwPj3b13vTjSyC1hhbUCSViwcg4J01lIz2s99SMioWbdXz/WmEVQze1Y+JuJWW30ULgtpANFKyFu8BgyPBtxgk5pQauAbdB5I3Qc+jH9d2idzHB3RoJMih/7Ljc/ez9fL5Of3qsGXxA='></script>
<script id='heateor_sssp_sharing_js-js-before'>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</script>
<script src='https://electionwiz.com/wp-content/plugins/sassy-social-share-premium/public/js/sassy-social-share-premium-public.js?ver=1.1.18' id='heateor_sssp_sharing_js-js'></script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='wordads_ccpa-js-extra'>
var ccpaSettings = {"defaultOptinCookieString":"1YNN","ccpaCssUrl":"https:\/\/electionwiz.com\/wp-content\/plugins\/jetpack\/css\/wordads-ccpa.min.css?ver=9.4","ajaxUrl":"https:\/\/electionwiz.com\/wp-admin\/admin-ajax.php","ajaxNonce":"5b0604207b","forceApplies":"false","strings":{"pleaseWait":"Please Wait"}};
</script>
<script type='text/javascript' src='https://electionwiz.com/_static/??-eJytjksOwjAMRC9EakVFZYU4CkoTt3KbxFE+rcrpiShIXcGGnT0znuc1CM0+o88QbBnJJ5gwB6VnWNAbjqBKZqdyJv1xhFWPTZBTIyZIseoJqHbEhDoTe+4TxgWjCGy3gaxtHPlmSqf1T7CDdKgmr20xNVUTdUXXo/lCVjMlhxnu9Q4Gju7Hh69cX8gaWDkaZXbQPgqtg3rDbu4qOym7y7mV7RPHnoTX'></script>

<script type="text/javascript">
jQuery(function($) { 
ga( 'send', 'pageview' );
 });
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=186101845&postid=5331&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Tell+the+Wiz+what+you+think%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.4&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=c5ae91788f60c473fe28a39c4a05e72b0755112e#parent=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=186101845&postid=5331&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Tell+the+Wiz+what+you+think%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.4&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=c5ae91788f60c473fe28a39c4a05e72b0755112e#parent=https%3A%2F%2Felectionwiz.com%2F2021%2F02%2F15%2Fron-desantis-tells-tucker-carlson-i-doubt-you-see-very-many-florida-licenses-plates-in-new-york%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202107.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'186101845',post:'5331',tz:'-5',srv:'electionwiz.com'} ]);
	_stq.push([ 'clickTrackerInit', '186101845', '5331' ]);
</script>
</body>
</html>

